基本上使用 gradle wrapper 應該沒有這樣的問題, 不過由於 gradle 1.8 需要 plugin 0.6 以上, 如果 project 與其他人共用, 版本又沒統一的狀況下 (比如怕有地雷..) 可以透過判斷 gradle version 的小技巧, 讓 project 可以在 gradle 1.7 & 1.8 下都能編譯.

參考 https://gist.github.com/shakalaca/6779748 修改 project root 的 build.gradle, 在 dependencies 判斷使用的 plugin 版本即可.

搭配 gradle wrapper 使用效果更好, 如果先前用 1.7 編譯完全沒問題, 而 1.8 無法正常編譯, 修改 task wrapper 中的 gradleVersion 後, 執行一次 ./gradlew wrapper 即可退版, 等到之後 plugin 或者 gradle 有修正再切換過去.

Comments

comments powered by Disqus